Wacom Pen Pressure Problem in After Effects CS5.5

Tonight I ran across a problem using a Wacom Intuos3 tablet with Adobe After Effects CS5.5. The pen pressure would not work with the brush tool in AE, and the brush acted as if I was using a plain old mouse. Having some detailed work to do, I needed both the Wacom pen input and pressure sensitivity, which I’ve fallen in love with for Photoshop use. (Seriously – if you do any significant amount of Photoshop work, get a Wacom tablet. It’s the best money you’ll spend.)

Since I’ve had far too many years of professionally dealing with PC troubleshooting, I went through all the normal steps you might expect: uninstall and reinstall the drivers, install different driver versions, blow away the preferences file, restart Windows, etc. Nothing worked. To be clear: this is a 64-bit install of Windows 7, and I tried Wacom driver versions 6.1.6-7 and 6.1.7-3, with the latest After Effects CS5.5 updates (reported as version

It struck me that the pen was working much like a mouse, I could gleefully get motion and clicking, but no pressure, tilt, or any of the good stuff. Remember, this is only in After Effects; the pen worked fine in Photoshop. During one of my uninstall / reboot / reinstall iterations, I noticed that Windows picked up the Wacom Intuos3 as a mouse, but of course nothing used the tablet features because there were no drivers installed. So, I checked the Device Manager, and found that there was a generic  “HID-compliant mouse” installed for the tablet. I verified the Vendor ID, and also unplugged my regular mouse to be certain it was the tablet. It was.

This made me suspect that perhaps After Effects was binding to a mouse driver before it got around to the Wacom tablet driver, precipitating the pressureless performance of the pen. I reinstalled the latest Wacom drivers, and checked back with the Device Manager, and found this:

Wacom Intuos3 Device Manager Entries

Notice that there are at least four devices associated with the Wacom Intuos3 tablet, which I highlighted in yellow. Two of them, under the Pointing Devices grouping, seemed very mouse-like, and probably serve to drive the pointer around. The other two, listed under Human Interface Devices, smelled a bit more tablet-specific, and probably provide the pressure, tilt, and other fun stuff to applications. This is just a guess on my part.

Going ahead with my theory that AE was binding to the wrong device first, I wanted to force After Effects to find the tablet drivers before the mouse drivers. I disabled the two Wacom mouse driver entries (which prevents the pen from moving the pointer, by the way), then launched After Effects, and finally re-enabled the two Wacom mouse devices.

It worked! Lovely, glorious pressure sensitivity! I could brush my roto masks with finesse! Retouching became fun instead of a chore! The promise of the pen was fulfilled! Oh, happy day.

My guess here is there is a bug on the Adobe end of things, whereby AE is binding to the mouse-flavoured drivers in lieu of the tablet-flavoured oens. I’ll go file a bug report with them shortly, and hopefully it will get cleared up in the next release. But for now, we have a workaround for the Wacom pen pressure not working in After Effects for the Brush tool:

  1. Disable the two devices: Wacom Mouse and Wacom Mouse Monitor
  2. Launch After Effects
  3. Enable the two devices disabled in the first step
  4. Scribble away!

And there we have it. A working, if annoying, method to enable Pen Pressure in After Effects!

Update: After you do this, if you use Wacom’s mouse on the tablet at all, AE will switch back to mouse mode and not use pressure with the pen. So, keep the mouse away from the pad! You can use a regular mouse just fine, but the tablet mouse will switch things back to sucky mode.


Aaron K.

Aaron Kondziela is a technologist and serial entrepreneur living in New York City.


Leave a Reply

Your email address will not be published. Required fields are marked *